k

Page:

Wojtek

[19-Nov-2018 09:14:00 Europe/Warsaw] PHP Notice:  Undefined offset: 13 in /opt/tinycp/www/mods/web/apache/inc/Apache.class.php on line 761
[19-Nov-2018 09:14:00 Europe/Warsaw] PHP Notice:  Undefined offset: 13 in /opt/tinycp/www/mods/web/apache/inc/Apache.class.php on line 761
[19-Nov-2018 09:14:00 Europe/Warsaw] PHP Notice:  Undefined offset: 13 in /opt/tinycp/www/mods/web/apache/inc/Apache.class.php on line 761
[19-Nov-2018 09:14:00 Europe/Warsaw] PHP Notice:  Undefined offset: 13 in /opt/tinycp/www/mods/web/apache/inc/Apache.class.php on line 761
[19-Nov-2018 09:14:00 Europe/Warsaw] PHP Notice:  Undefined offset: 13 in /opt/tinycp/www/mods/web/apache/inc/Apache.class.php on line 761
[19-Nov-2018 09:14:00 Europe/Warsaw] PHP Notice:  Undefined offset: 13 in /opt/tinycp/www/mods/web/apache/inc/Apache.class.php on line 761
[19-Nov-2018 09:14:00 Europe/Warsaw] PHP Notice:  Undefined offset: 13 in /opt/tinycp/www/mods/web/apache/inc/Apache.class.php on line 761
[19-Nov-2018 09:14:00 Europe/Warsaw] PHP Notice:  Undefined offset: 13 in /opt/tinycp/www/mods/web/apache/inc/Apache.class.php on line 761
[19-Nov-2018 09:14:00 Europe/Warsaw] PHP Notice:  Undefined offset: 13 in /opt/tinycp/www/mods/web/apache/inc/Apache.class.php on line 761
[19-Nov-2018 09:14:00 Europe/Warsaw] PHP Notice:  Undefined offset: 13 in /opt/tinycp/www/mods/web/apache/inc/Apache.class.php on line 761
[19-Nov-2018 09:14:00 Europe/Warsaw] PHP Notice:  Undefined offset: 13 in /opt/tinycp/www/mods/web/apache/inc/Apache.class.php on line 761

I hope this will help. Thank you for your attention. 

Wojtek

root@panel:~# wget -qO- http://localhost/tinycp-status-entry | grep th

<tr><th>PID</th><th>Connections</th>

<th>Threads</th><th>Async connections</th></tr>

<tr><th>total</th><th>accepting</th><th>busy</th><th>idle</th><th>writing</th><t >keep-alive</th><th>closing</th></tr>

"<b><code>.</code></b>" Open slot with no current process<br />

<table><tr><th>Srv</th><th>PID</th><th>Acc</th><th>M</th><th>CPU

</th><th>SS</th><th>Req</th><th>Conn</th><th>Child</th><th>Slot</th><th>Client</th><th>VHost</th><th>Request</th></tr>

 <tr><th>Srv</th><td>Child Server number - generation</td></tr>

 <tr><th>PID</th><td>OS process ID</td></tr>

 <tr><th>Acc</th><td>Number of accesses this connection / this child / this slot</td></tr>

 <tr><th>M</th><td>Mode of operation</td></tr>

<tr><th>CPU</th><td>CPU usage, number of seconds</td></tr>

<tr><th>SS</th><td>Seconds since beginning of most recent request</td></tr>

 <tr><th>Req</th><td>Milliseconds required to process most recent request</td></tr>

 <tr><th>Conn</th><td>Kilobytes transferred this connection</td></tr>

 <tr><th>Child</th><td>Megabytes transferred this child</td></tr>

 <tr><th>Slot</th><td>Total megabytes transferred this slot</td></tr>

cache type: <b>SHMCB</b>, shared memory: <b>512000</b> bytes, current entries: <b>0</b><br>subcaches: <b>32</b>, indexes per subcache: <b>88</b><br>index usage: <b>0%</b>, cache usage: <b>0%</b><br>total entries stored since starting: <b>6</b><br>total entries replaced since starting: <b>0</b><br>total entries expired since starting: <b>6</b><br>total (pre-expiry) entries scrolled out of the cache: <b>0</b><br>total retrieves since starting: <b>0</b> hit, <b>7</b> miss<br>total removes since starting: <b>0</b> hit, <b>0</b> miss<br></td></tr>


I hope this will help.

I understand now. 

If that would be the case, I will just choose TinyCP firewall for now. By any chance, could you tell me what Im missing here? I tried to drop any connection to my ssh service as shown below:

restarted SSH, and re-connect to SSH via PuTTy, however, I am still getting the SSH port access. By chance, do you have docs on how to manage firewall in TinyCP?
Thank you for your attention. 

Hello Team,

I tried to enable http2 here in my ubuntu 16, and I tried this link below, 
https://techwombat.com/enable-http2-apache-ubuntu-16-04/

However, I am still no idea where to a get the Step 4: Add a line to your Virtual Host file

Protocols h2 h2c http/1.1 

At this point, I was able to make it work for one of my domain by:
/opt/tinycp/domains/domain.tld/apache.conf

However, is there any option to get the entire domain to enable for https2? 

I tried /etc/apache2/apache2.conf, however, I do not see the <VirtualHost>...</VirtualHost> tags. Could you guide me in the right direction? 

Server version: Apache/2.4.37 (Ubuntu) Server built:   2018-10-28T15:26:37 
Version number: 437
have you tried to FTP > Explore > your domain directory ?
from there, delete all files ?

Have the same error message, tried to delete SSL, however, received this message below:

Fatal error: Uncaught Error: Cannot use object of type stdClass as array in /opt/tinycp/www/mods/web/apache/domain-ssl-acme.php:330 Stack trace: #0 /opt/tinycp/www/inc/UrlHandler.class.php(52): include() #1 /opt/tinycp/www/index.php(223): UrlHandler->IncludeFile() #2 {main} thrown in /opt/tinycp/www/mods/web/apache/domain-ssl-acme.php on line 330
At this point, I can no longer add SSL to my desired domain.Ubuntu 16.04.5 LTS
Version number: 462

Any updates?

Found a quick fix.

Went to /opt/tinycp/domains/domain.name/ssl/

Deleted these files instead.

From here, generate a new SSL for your domain. This should work now, but this is just a temporary fix. 

Write a reply Edit a reply