[TESTING] Let's Encrypt Fails

Reported by: checho
Created: 10 months 14 days ago
Last reply: 6 months 9 days ago
Views: 70

[Tue Sep 04 08:03:28.532304 2018] [core:error] [pid 14272] (13)Permission denied: [client xxx:38654] AH00035: access to /.well-known/acme-challenge/ denied (filesystem path '/opt/tinycp/domains/xxx') because search permissions are missing on a component of the path
[Mon Sep 03 21:32:51.174685 2018] [core:error] [pid 21746] (13)Permission denied: [client xxx:44553] AH00035: access to /.well-known/acme-challenge/ok2ezpM5q2IpNBsi12LI2k3nKGVdWDckyV960q0q5uQ denied (filesystem path '/opt/tinycp/domains/xxx') because search permissions are missing on a component of the path, referer: http://xxx:8080/web/domains/domain;xxx/ssl-acme/

always the same error, I tried to give other directory or file permissions but it doesn't work.

Hey Folks,

Yeah I had the same issue but was able to resolve it by performing the following steps

  1. Get to where it fails to verify the challenge within TinyCP
  2. Navigate to /opt/tinycp
  3. perform chmod +x on the following folders
    • opt/tinycp/domains
    • opt/tinycp/domains/<domain.name>
    • opt/tinycp/domains/<domain.name>/ssl
    • opt/tinycp/domains/<domain.name>/ssl/acme
    • opt/tinycp/domains/<domain.name>/ssl/acme/challenges
  4. navigate to opt/tinycp/domains/<domain.name>/ssl and perform the following command
    • chown -R www-data:www-data acme
  5. Restart Apache (service apache2 restart)

This should be updated in the process by the TinyCP Folks

In update 269 we have added the small fix for that.
Just do update and problem should be solved.

Not sure if you wanted a new bug report or not but after updating, when I attempt to create a new LetsEncrypt cert, I receive the following error
- Warning: mkdir(): File exists in /opt/tinycp/www/mods/web/apache/inc/ACME.class.php on line 281

This is a freshly added domain. The challenge is apparently created correctly because restarting apache allows me to verify the challenge and complete the certificate after seeing the error again twice in the CSR portion of the process.

ACME.class.php 281 line warning fixed.

I wait a litle until I close this thread, maybe some other warning or notices appear.

On fresh TinyCP install I still have to do:

chmod +x /opt/tinycp/domains/

before LE verification process can be done successfully.

I am in version Version number: 462, with freshly install tinycp in Ubuntu 16.04.5 LTS. Still have the same problem? do you have tutorial to show how to fix this?

Write a reply Edit a reply