[SOLVED] Please fix default apache2.conf and remove the Indexes option

Reported by: RickoT
Created: 10 months 13 days ago
Last reply: 10 months 12 days ago
Views: 13

By default, indexes should not be configured, if someone wants this it should be something required to be enabled. Please update the apache2.conf file when apache is installed to change the configuration as noted below

<Directory />
Options FollowSymLinks
AllowOverride None
Require all denied
</Directory>

<Directory /usr/share>
AllowOverride None
Require all granted
</Directory>

<Directory /var/www/>
Options Indexes FollowSymLinks <-- Remove the Indexes option from this line when Apache is installed
AllowOverride None
Require all granted
</Directory>

We leave almost everything in apache.conf as default except one include.

#tinyCP
IncludeOptional /opt/tinycp/domains/*/apache.conf

We have no plan to make configuration of everything in apache because there are thousands of options.
Do it yourself, if you need it. TinyCP wont override your settings.

We have decided to add following options by default for each domain.
Default apache.conf is still without modifications.

<Directory "/var/www/domain.com" >
AllowOverride All
Options Includes FollowSymLinks
</Directory>

Version 274 includes it

Write a reply Edit a reply