Installing SSL certificate

Reported by: Info
Created: 13 days ago
Last reply: 6 days ago
Views: 39

Unable to activate Let's Encrypt for a domain. Trying to install a certificate from a third party. Have the files (1 x .pem / 2 x .crt). Is it possible to install via the TinyCP interface? Have tried to enter certificate information a couple of times and my entire list of domains disappeared(!). Things went back to normal when I deleted the certificate information I tried to enter. Thank you for any assistance. 

(Trying Let's Encrypt again. Error = "Unable to perform validation for challenge :: authorization must be pending")

Things are so quiet around here, people have time to kick things around ;-)

Two things:
- Let's Encrypt does not seem to like domains non-authoritative domains (i.e. if an A record only is pointing your way). Verification fails.
- If you wish to install another type of SSL certificate, select and activate "selfsigned" then deactivate it before installing the outside certificate. 
(I have installed a certificate from GoDaddy for one domain. Browsers do not throw an error, but SSL verification shows the certificate as "not trusted".
Have not figured out how to fix that).

(Answering myself is fun...)
Have installed two SSL certificates (other than Let's Encrypt) successfully: 1 x GoDaddy / 1 x SSLs.com.
Procedure: "Add SSL" - give certificate a name, enter information (country, etc.), click "Generate CSR" (this will populate "CSR" and "Private Key"fields). 
Obtain certificate file from issuer (.crt) open with text editor and paste into "Certificate" field. Repeat with "bundle" file - paste into "Certification Authorities (CA)" field. 
The trick (as I have found) is to save all settings, switch to another certificate (i.e. selfsigned) and then re-apply the new certificate. If you save settings cumulatively, the CP will not recognize them. Re-apply your fully populated settings all at once. 

Write a reply Edit a reply