Error installing LXD Linux Containers

Reported by: Nikit_OS
Created: 9 months 2 days ago
Last reply: 8 months 29 days ago
Views: 270
Hello, post creation was broken for a while when uploading images. Can you please post your message again?

Hello, i tried to install LXD Linux Containers. I have 

Linux debian 4.19.0-8-amd64 #1 SMP Debian 4.19.98-1 (2020-01-26) x86_64 GNU/Linux

Tried install via features tab, but have this output:

apt-get -y install lxd

Reading package lists... Building dependency tree... Reading state information... Package lxd is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'lxd' has no installation candidate

apt-get -y install lxd-client lxc-utils

Reading package lists... Building dependency tree... Reading state information...

E: Unable to locate package lxd-client E: Unable to locate package lxc-utils

apt-get -y install zfsutils-linux

Reading package lists... Building dependency tree... Reading state information... zfsutils-linux is already the newest version (0.7.12-2+deb10u1).

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Installed manually via snap, but it not shows installded in features tab

Hi,

Lxd is not native available at Debian. Only via snap raft.io.

So if you want to install und manage Lxd via tinycp, you have to go with Ubuntu and drop Debian. 

Join our Discord server
Write a reply Edit a reply